using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^ +\w+([A-Z][a-z]+) += +(?:(?!\1)\w)+$";
string input = @"
aaaBbb = CccBbb
aaaDddd = CccDddd
aaaEeee = CccFfff
aaaDddd = CccDdddd
2 matches found...
But I want to match the 3rd line without matching the first 2";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}