re = /^ +\w+([A-Z][a-z]+) += +(?:(?!\1)\w)+$/m
str = '
aaaBbb = CccBbb
aaaDddd = CccDddd
aaaEeee = CccFfff
aaaDddd = CccDdddd
2 matches found...
But I want to match the 3rd line without matching the first 2'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end