# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\.\s/ - /g;t' <<< "01. Title (feat. John Doe).mp3
4. Song (feat. Jane.Doe).flac
23. Name.Title.m4a"