use strict;
my $str = '01. Title (feat. John Doe).mp3
4. Song (feat. Jane.Doe).flac
23. Name.Title.m4a';
my $regex = qr/\.\s/p;
my $subst = ' - ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";