// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\.\s").unwrap();
let string = "01. Title (feat. John Doe).mp3
4. Song (feat. Jane.Doe).flac
23. Name.Title.m4a";
let substitution = " - ";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}