$re = '/\.\s/';
$str = '01. Title (feat. John Doe).mp3
4. Song (feat. Jane.Doe).flac
23. Name.Title.m4a';
$subst = " - ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;