use strict;
my $str = 'IRS No.: 208677788 | State of Incorp.: CO | Fiscal Year End: 0630Type: 10-K | Act: 34 | File No.: 000-53875 | Film No.: 161939487SIC: 5960 Retail-Nonstore RetailersAssistant Director 2';
my $regex = qr/SIC:\s(\d{2,})\s/p;
if ( $str =~ /$regex/g ) {
  print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
  # print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
  # print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}