// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"SIC:\s(\d{2,})\s").unwrap();
let string = "IRS No.: 208677788 | State of Incorp.: CO | Fiscal Year End: 0630Type: 10-K | Act: 34 | File No.: 000-53875 | Film No.: 161939487SIC: 5960 Retail-Nonstore RetailersAssistant Director 2";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}