const regex = /\.[xy]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\.[xy]', 'gm')
const str = `company
deriv.x
isConfirmed.y`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);