$re = '/\.[xy]/m';
$str = 'company
deriv.x
isConfirmed.y';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;