use strict;
my $str = 'company
deriv.x
isConfirmed.y';
my $regex = qr/\.[xy]/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";