package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^123-(?:a[a-z]*-(*SKIP)(*F)|\w+-)?456$`)
var str = `123-456
123-7-456
123-Apple-456
123-0-456
123-Alphabet-456
123-b-456`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}