re = /^123-(?:a[a-z]*-(*SKIP)(*F)|\w+-)?456$/mi
str = '123-456
123-7-456
123-Apple-456
123-0-456
123-Alphabet-456
123-b-456'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end