import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^123-(?:a[a-z]*-(*SKIP)(*F)|\\w+-)?456$";
final String string = "123-456\n"
+ "123-7-456\n"
+ "123-Apple-456\n"
+ "123-0-456\n"
+ "123-Alphabet-456\n"
+ "123-b-456";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}