use strict;
my $str = '123-456
123-7-456
123-Apple-456
123-0-456
123-Alphabet-456
123-b-456';
my $regex = qr/^123-(?:a[a-z]*-(*SKIP)(*F)|\w+-)?456$/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}