#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?isu)<table.+?Время.+?</table>"
Local $sString = "<p>Текст</p>" & @CRLF & _
"" & @CRLF & _
"<table>" & @CRLF & _
" <tr>" & @CRLF & _
" <td>разные данные</td>" & @CRLF & _
" </tr>" & @CRLF & _
"</table>" & @CRLF & _
"" & @CRLF & _
"<table>" & @CRLF & _
" <tr>" & @CRLF & _
" <td>Режим</td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <td>Тратата</td>" & @CRLF & _
" </tr>" & @CRLF & _
"</table>" & @CRLF & _
"" & @CRLF & _
"<p>Текст</p>" & @CRLF & _
"" & @CRLF & _
"<table>" & @CRLF & _
" <tr>" & @CRLF & _
" <td>Время</td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <td>Тратата</td>" & @CRLF & _
" </tr>" & @CRLF & _
"</table>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")