const regex = new RegExp('<table.+?Время.+?</table>', 'isug')
const str = `<p>Текст</p>
<table>
<tr>
<td>разные данные</td>
</tr>
</table>
<table>
<tr>
<td>Режим</td>
</tr>
<tr>
<td>Тратата</td>
</tr>
</table>
<p>Текст</p>
<table>
<tr>
<td>Время</td>
</tr>
<tr>
<td>Тратата</td>
</tr>
</table>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}