import re
regex = re.compile(r"<table.+?Время.+?</table>", flags=re.IGNORECASE | re.DOTALL | re.UNICODE)
test_str = ("<p>Текст</p>\n\n"
"<table>\n"
" <tr>\n"
" <td>разные данные</td>\n"
" </tr>\n"
"</table>\n\n"
"<table>\n"
" <tr>\n"
" <td>Режим</td>\n"
" </tr>\n"
" <tr>\n"
" <td>Тратата</td>\n"
" </tr>\n"
"</table>\n\n"
"<p>Текст</p>\n\n"
"<table>\n"
" <tr>\n"
" <td>Время</td>\n"
" </tr>\n"
" <tr>\n"
" <td>Тратата</td>\n"
" </tr>\n"
"</table>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")