$re = '~<table.+?Время.+?</table>~isu';
$str = '<p>Текст</p>
<table>
<tr>
<td>разные данные</td>
</tr>
</table>
<table>
<tr>
<td>Режим</td>
</tr>
<tr>
<td>Тратата</td>
</tr>
</table>
<p>Текст</p>
<table>
<tr>
<td>Время</td>
</tr>
<tr>
<td>Тратата</td>
</tr>
</table>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);