package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.*?)((0|1)?\d)-((0|1|2|3)?\d)-(19|20\d\d)(.*?)$`)
var str = `asasa12-12-1993.txt
asassa12-12-2010.txt
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}