// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(.*?)((0|1)?\d)-((0|1|2|3)?\d)-(19|20\d\d)(.*?)$").unwrap();
let string = "asasa12-12-1993.txt
asassa12-12-2010.txt
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}