$re = '/^(.*?)((0|1)?\d)-((0|1|2|3)?\d)-(19|20\d\d)(.*?)$/m';
$str = 'asasa12-12-1993.txt
asassa12-12-2010.txt
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);