re = /^(.*?)((0|1)?\d)-((0|1|2|3)?\d)-(19|20\d\d)(.*?)$/m
str = 'asasa12-12-1993.txt
asassa12-12-2010.txt
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end