using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\s*(?<nodename>\w+)\s*(?<nodevalue>.*)[^{]$";
string input = @"value CDTR ::= Record : {
origAddress {
ton xxx,
npi yyy,
pid xxx,
msisdn ""xxx"",
dididk9 {xxx}
},
origAddressGSM 'xxxx'H,
recipAddress {
ton xxx,
npi xxx,
pid xxxx,
msisdn ""xxxx""
},
recipAddressGSM 'xxxxx'H,
submitDate 'xxx'H,
submitTime 'xxxx'H,
status xxx,
terminDate 'xxx'H,
terminTime 'xxx'H,
lengthOfMessage xxx,
prioIndicator xxx,
validityPeriod {
hours x,
minutes xxx
},
deferIndicator xxx,
notifIndicator xxx,
vsmscid xxxx,
vsmsctype xxx,
orglSubmitDate 'xxx'H,
orglSubmitTime 'xxxx'H,
transparentPid 1,
intlMobileSubId 'xxxx'H,
callingLineId {
ton xxxx,
npi xxx,
pid xxx,
msisdn ""xxx""
},
callingLineIdGSM 'xxxx'H,
consolidation ""xxxx"",
portNumber xxxx,
aser {},
mser {xxx},
nser {xxx},
xser {},
ppPser {xxx-pp},
cmReferenceNr xxx,
currentSegment xxx,
segmentsTotal xxxx
}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}