use strict;
my $str = 'value CDTR ::= Record : {
origAddress {
ton xxx,
npi yyy,
pid xxx,
msisdn "xxx",
dididk9 {xxx}
},
origAddressGSM \'xxxx\'H,
recipAddress {
ton xxx,
npi xxx,
pid xxxx,
msisdn "xxxx"
},
recipAddressGSM \'xxxxx\'H,
submitDate \'xxx\'H,
submitTime \'xxxx\'H,
status xxx,
terminDate \'xxx\'H,
terminTime \'xxx\'H,
lengthOfMessage xxx,
prioIndicator xxx,
validityPeriod {
hours x,
minutes xxx
},
deferIndicator xxx,
notifIndicator xxx,
vsmscid xxxx,
vsmsctype xxx,
orglSubmitDate \'xxx\'H,
orglSubmitTime \'xxxx\'H,
transparentPid 1,
intlMobileSubId \'xxxx\'H,
callingLineId {
ton xxxx,
npi xxx,
pid xxx,
msisdn "xxx"
},
callingLineIdGSM \'xxxx\'H,
consolidation "xxxx",
portNumber xxxx,
aser {},
mser {xxx},
nser {xxx},
xser {},
ppPser {xxx-pp},
cmReferenceNr xxx,
currentSegment xxx,
segmentsTotal xxxx
}';
my $regex = qr/^\s*(?<nodename>\w+)\s*(?<nodevalue>.*)[^{]$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}