$re = '/^\s*(?<nodename>\w+)\s*(?<nodevalue>.*)[^{]$/m';
$str = 'value CDTR ::= Record : {
origAddress {
ton xxx,
npi yyy,
pid xxx,
msisdn "xxx",
dididk9 {xxx}
},
origAddressGSM \'xxxx\'H,
recipAddress {
ton xxx,
npi xxx,
pid xxxx,
msisdn "xxxx"
},
recipAddressGSM \'xxxxx\'H,
submitDate \'xxx\'H,
submitTime \'xxxx\'H,
status xxx,
terminDate \'xxx\'H,
terminTime \'xxx\'H,
lengthOfMessage xxx,
prioIndicator xxx,
validityPeriod {
hours x,
minutes xxx
},
deferIndicator xxx,
notifIndicator xxx,
vsmscid xxxx,
vsmsctype xxx,
orglSubmitDate \'xxx\'H,
orglSubmitTime \'xxxx\'H,
transparentPid 1,
intlMobileSubId \'xxxx\'H,
callingLineId {
ton xxxx,
npi xxx,
pid xxx,
msisdn "xxx"
},
callingLineIdGSM \'xxxx\'H,
consolidation "xxxx",
portNumber xxxx,
aser {},
mser {xxx},
nser {xxx},
xser {},
ppPser {xxx-pp},
cmReferenceNr xxx,
currentSegment xxx,
segmentsTotal xxxx
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);