import Foundation
let pattern = #"^\s*(?<nodename>\w+)\s*(?<nodevalue>.*)[^{]$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
value CDTR ::= Record : {
origAddress {
ton xxx,
npi yyy,
pid xxx,
msisdn "xxx",
dididk9 {xxx}
},
origAddressGSM 'xxxx'H,
recipAddress {
ton xxx,
npi xxx,
pid xxxx,
msisdn "xxxx"
},
recipAddressGSM 'xxxxx'H,
submitDate 'xxx'H,
submitTime 'xxxx'H,
status xxx,
terminDate 'xxx'H,
terminTime 'xxx'H,
lengthOfMessage xxx,
prioIndicator xxx,
validityPeriod {
hours x,
minutes xxx
},
deferIndicator xxx,
notifIndicator xxx,
vsmscid xxxx,
vsmsctype xxx,
orglSubmitDate 'xxx'H,
orglSubmitTime 'xxxx'H,
transparentPid 1,
intlMobileSubId 'xxxx'H,
callingLineId {
ton xxxx,
npi xxx,
pid xxx,
msisdn "xxx"
},
callingLineIdGSM 'xxxx'H,
consolidation "xxxx",
portNumber xxxx,
aser {},
mser {xxx},
nser {xxx},
xser {},
ppPser {xxx-pp},
cmReferenceNr xxx,
currentSegment xxx,
segmentsTotal xxxx
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)