using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\/en(\/.+)$";
string input = @".com/en/testing.aspx
.com/en/testing.aspx
.com/option/en/sub1/sub2/testing.aspx";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}