re = /\/en(\/.+)$/m
str = '.com/en/testing.aspx
.com/en/testing.aspx
.com/option/en/sub1/sub2/testing.aspx'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end