// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\/en(\/.+)$").unwrap();
let string = ".com/en/testing.aspx
.com/en/testing.aspx
.com/option/en/sub1/sub2/testing.aspx";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}