const regex = /\/en(\/.+)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/en(\\\/.+)$', 'gm')
const str = `.com/en/testing.aspx
.com/en/testing.aspx
.com/option/en/sub1/sub2/testing.aspx`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}