re = /^.+?(AAA\s+\S+)/m
str = 'NAME: "test1", DESCR: "AAA 1111S ABC 48 BB (4 BBBB) TEST1 "'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end