#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mu)(?:[\s,:!&@$%^.]|\\n|(?<!\w)'|'(?: |$))+"
Local $sString = "word" & @CRLF & _
"one of each" & @CRLF & _
"one fish two fish red fish blue fish" & @CRLF & _
"one,two,three" & @CRLF & _
"one,\ntwo,\nthree" & @CRLF & _
"car : carpet as java : javascript!!&@$%^&" & @CRLF & _
"testing, 1, 2 testing" & @CRLF & _
"go Go GO Stop stop" & @CRLF & _
"First: don't laugh. Then: don't cry." & @CRLF & _
"Joe can't tell between app, apple and a." & @CRLF & _
"Joe can't tell between 'large' and large." & @CRLF & _
" multiple whitespaces" & @CRLF & _
",\n,one,\n ,two \n 'three'"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")