using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:[\s,:!&@$%^.]|\\n|(?<!\w)'|'(?: |$))+";
string input = @"word
one of each
one fish two fish red fish blue fish
one,two,three
one,\ntwo,\nthree
car : carpet as java : javascript!!&@$%^&
testing, 1, 2 testing
go Go GO Stop stop
First: don't laugh. Then: don't cry.
Joe can't tell between app, apple and a.
Joe can't tell between 'large' and large.
multiple whitespaces
,\n,one,\n ,two \n 'three'";
RegexOptions options = RegexOptions.Multiline | RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}