use strict;
my $str = 'word
one of each
one fish two fish red fish blue fish
one,two,three
one,\\ntwo,\\nthree
car : carpet as java : javascript!!&@$%^&
testing, 1, 2 testing
go Go GO Stop stop
First: don\'t laugh. Then: don\'t cry.
Joe can\'t tell between app, apple and a.
Joe can\'t tell between \'large\' and large.
multiple whitespaces
,\\n,one,\\n ,two \\n \'three\'';
my $regex = qr/(?:[\s,:!&@$%^.]|\\n|(?<!\w)'|'(?: |$))+/mup;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}