import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:[\\s,:!&@$%^.]|\\\\n|(?<!\\w)'|'(?: |$))+";
final String string = "word\n"
+ "one of each\n"
+ "one fish two fish red fish blue fish\n"
+ "one,two,three\n"
+ "one,\\ntwo,\\nthree\n"
+ "car : carpet as java : javascript!!&@$%^&\n"
+ "testing, 1, 2 testing\n"
+ "go Go GO Stop stop\n"
+ "First: don't laugh. Then: don't cry.\n"
+ "Joe can't tell between app, apple and a.\n"
+ "Joe can't tell between 'large' and large.\n"
+ " multiple whitespaces\n"
+ ",\\n,one,\\n ,two \\n 'three'";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}