const regex = /\b(?<!'\w|\w')[\w'\\]+(?!'\w|\w')\b/gmu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?<!\'\\w|\\w\')[\\w\'\\\\]+(?!\'\\w|\\w\')\\b', 'gmu')
const str = `word
one of each
one fish two fish red fish blue fish
one,two,three
one,\\ntwo,\\nthree
car : carpet as java : javascript!!&@\$%^&
testing, 1, 2 testing
go Go GO Stop stop
First: don't laugh. Then: don't cry.
Joe can't tell between app, apple and a.
Joe can't tell between 'large' and large.
multiple whitespaces
,\\n,one,\\n ,two \\n 'three'`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}