re = /\b(?<!'\w|\w')[\w'\\]+(?!'\w|\w')\b/m
str = 'word
one of each
one fish two fish red fish blue fish
one,two,three
one,\\ntwo,\\nthree
car : carpet as java : javascript!!&@$%^&
testing, 1, 2 testing
go Go GO Stop stop
First: don\'t laugh. Then: don\'t cry.
Joe can\'t tell between app, apple and a.
Joe can\'t tell between \'large\' and large.
multiple whitespaces
,\\n,one,\\n ,two \\n \'three\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end