import Foundation
// WARNING: You included a flag that Swift doesn't support: u
// When this flag is set, it makes the pattern and subject strings to be treated as unicode.
// Swift already treats the pattern and subject strings as unicode by default, so including this flag is redundant.
let pattern = #"\b(?<!'\w|\w')[\w'\\]+(?!'\w|\w')\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
word
one of each
one fish two fish red fish blue fish
one,two,three
one,\ntwo,\nthree
car : carpet as java : javascript!!&@$%^&
testing, 1, 2 testing
go Go GO Stop stop
First: don't laugh. Then: don't cry.
Joe can't tell between app, apple and a.
Joe can't tell between 'large' and large.
multiple whitespaces
,\n,one,\n ,two \n 'three'
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)