# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\b(?<!'\w|\w')[\w'\\]+(?!'\w|\w')\b"
test_str = ("word\n"
"one of each\n"
"one fish two fish red fish blue fish\n"
"one,two,three\n"
"one,\\ntwo,\\nthree\n"
"car : carpet as java : javascript!!&@$%^&\n"
"testing, 1, 2 testing\n"
"go Go GO Stop stop\n"
"First: don't laugh. Then: don't cry.\n"
"Joe can't tell between app, apple and a.\n"
"Joe can't tell between 'large' and large.\n"
" multiple whitespaces\n"
",\\n,one,\\n ,two \\n 'three'")
matches = re.finditer(regex, test_str, re.MULTILINE | re.UNICODE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.