package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?ms)({LOOP})(.*?)({ENDLOOP})`)
var str = `{LOOP}
<option value="%SEL-VL%">%SEL-TXT%</option>
{ENDLOOP}
{LOOP}
<span>Name %s</span>
{ENDLOOP}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}