import re
regex = re.compile(r"({LOOP})(.*?)({ENDLOOP})", flags=re.MULTILINE | re.DOTALL)
test_str = ("{LOOP}\n"
" <option value=\"%SEL-VL%\">%SEL-TXT%</option>\n"
"{ENDLOOP}\n\n"
"{LOOP}\n"
" <span>Name %s</span>\n"
"{ENDLOOP}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")