re = /({LOOP})(.*?)({ENDLOOP})/m
str = '{LOOP}
<option value="%SEL-VL%">%SEL-TXT%</option>
{ENDLOOP}
{LOOP}
<span>Name %s</span>
{ENDLOOP}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end