// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\d+\/\d+\/\d+\s+\d+:\d+\s\d+\s+(?<your_field>.*)").unwrap();
let string = "03/01/2019 07:10 0 MBAM CLIENT (2.5_64b) EN.$w$";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}