const regex = /^([[:digit:]]{4})\-([[:digit:]]{2})\-([[:digit:]]{2}T[[:digit:]]{2})\:([[:digit:]]{2})\:([[:digit:]]{2})UTC$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([[:digit:]]{4})\\-([[:digit:]]{2})\\-([[:digit:]]{2}T[[:digit:]]{2})\\:([[:digit:]]{2})\\:([[:digit:]]{2})UTC$', 'gm')
const str = `2021-05-09T14:23:38UTC`;
const subst = `$1$2$3$4$5T`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);