import re
regex = re.compile(r"^([[:digit:]]{4})\-([[:digit:]]{2})\-([[:digit:]]{2}T[[:digit:]]{2})\:([[:digit:]]{2})\:([[:digit:]]{2})UTC$", flags=re.MULTILINE)
test_str = "2021-05-09T14:23:38UTC"
subst = "$1$2$3$4$5T"
result = regex.sub(subst, test_str)
if result:
print(result)