// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([[:digit:]]{4})\-([[:digit:]]{2})\-([[:digit:]]{2}T[[:digit:]]{2})\:([[:digit:]]{2})\:([[:digit:]]{2})UTC$").unwrap();
let string = "2021-05-09T14:23:38UTC";
let substitution = "$1$2$3$4$5T";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}