#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\w+)\W+\w+\W+(\w+)"
Local $sString = "health status index pri rep docs.count docs.deleted store.size pri.store.size " & @CRLF & _
"yellow open first_index 5 1 222173 0 43.8gb 43.8gb " & @CRLF & _
"green open second_index 5 1 27131 7 36.6gb 36.6gb " & @CRLF & _
"red open third_index 5 1 4047 0 22.4mb 22.4mb " & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")