const regex = new RegExp('^(\\w+)\\W+\\w+\\W+(\\w+)', 'gm')
const str = `health status index pri rep docs.count docs.deleted store.size pri.store.size
yellow open first_index 5 1 222173 0 43.8gb 43.8gb
green open second_index 5 1 27131 7 36.6gb 36.6gb
red open third_index 5 1 4047 0 22.4mb 22.4mb
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}