# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(\w+)\W+\w+\W+(\w+)"
test_str = ("health status index pri rep docs.count docs.deleted store.size pri.store.size \n"
"yellow open first_index 5 1 222173 0 43.8gb 43.8gb \n"
"green open second_index 5 1 27131 7 36.6gb 36.6gb \n"
"red open third_index 5 1 4047 0 22.4mb 22.4mb \n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.